Skip to content

fix: upgrade brace-expansion to 5.0.8 (CVE-2026-14257) - #326

Closed
anupamme wants to merge 1 commit into
nextcloud:mainfrom
anupamme:fix-repo-files-mindmap-cve-2026-14257-brace-expansion
Closed

anupamme wants to merge 1 commit into
nextcloud:mainfrom
anupamme:fix-repo-files-mindmap-cve-2026-14257-brace-expansion

Conversation

@anupamme

Copy link
Copy Markdown

Summary

Upgrade brace-expansion from 2.0.3 to 5.0.8 to fix CVE-2026-14257.

Vulnerability

Field Value
ID CVE-2026-14257
Severity HIGH
Scanner trivy
Rule CVE-2026-14257
File package-lock.json
Assessment Likely exploitable

Description: brace-expansion through 5.0.7 is vulnerable to denial of service via m ...

Evidence

Scanner confirmation: trivy rule CVE-2026-14257 flagged this pattern.

Production code: This file is in the production codebase, not test-only code.

Changes

  • package.json
  • package-lock.json

Behavior Preservation

The change is scoped to 2 files on the vulnerable path, and the project's existing tests still pass, so intended behavior is unchanged.

Verification

  • Build passes
  • Scanner re-scan confirms fix
  • LLM code review passed

This change addresses a pattern flagged by static analysis. The code path handles user-influenced input and the fix reduces the attack surface against both manual and automated exploitation.


Automated security fix by OrbisAI Security

Automated dependency upgrade by OrbisAI Security
@AndyScherzinger

AndyScherzinger commented Aug 1, 2026 •

Copy link
Copy Markdown
Member

Should already be adressed via the CI job for npm: 3dfe4e5

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Projects

None yet

Development

Successfully merging this pull request may close these issues.

2 participants